Navigation - Mercedes GLE Forum
 
Thread Tools
post #1 of 7 (permalink) Old 09-12-2015, 10:14 PM Thread Starter
Junior Member
 
Join Date: Sep 2015
Location: NJ
Posts: 3
(Thread Starter)
Navigation

Just picked up the 2016 GLE 400. Anyone having issue with Navigation announcements not including the street/road/ave name, and instead only the route number? For example, instead of "Turn left on Main St." it says "Turn left on Route 124"

For any road that has a county route number, the navigation system verbally uses that and does not use its more common name. It does show the common name on the display as the next turn, interestingly enough.

I cannot find any setting that fixes this.

Anyone have a suggestion?
joeowen is offline  
post #2 of 7 (permalink) Old 09-15-2015, 02:18 PM
Senior Member
 
Join Date: Aug 2015
Posts: 158
I wasn't able to find anything regarding this in the 2016 GLE operator's manual. Maybe I missed something. Did you take a look at the manual first? You can also try emailing Mercedes via their contact us form.

Sorry I can't help you more.
Benzinator is offline  
post #3 of 7 (permalink) Old 09-15-2015, 04:48 PM Thread Starter
Junior Member
 
Join Date: Sep 2015
Location: NJ
Posts: 3
(Thread Starter)
Thanks for your reply! I couldn't find anything in the manual, but admit i have not read it cover-to-cover. The dealer has not heard of this issue, nor is aware of a fix.
joeowen is offline  
 
post #4 of 7 (permalink) Old 09-15-2015, 05:03 PM
Senior Member
 
Join Date: Jan 2015
Posts: 167
Seems like something to be in the service manual.
Shame they don't include more things in the owners manual. Decades ago they used to tell you how to change a crankshaft, now it just tells you what a light on your dash might mean.



stephen is offline  
post #5 of 7 (permalink) Old 09-15-2015, 06:48 PM Thread Starter
Junior Member
 
Join Date: Sep 2015
Location: NJ
Posts: 3
(Thread Starter)
@stephen totally agree. I'll let you guys know if I hear anything from the Contact Us group. *fingers crossed*
joeowen is offline  
post #6 of 7 (permalink) Old 09-27-2015, 09:37 PM
Member
 
Join Date: Apr 2015
Posts: 74
try going to a dealer and trying another glee with nav, see if it does the same thing...
Manalishi is offline  
post #7 of 7 (permalink) Old 02-13-2019, 03:38 PM
Junior Member
 
Join Date: Oct 2017
Location: Geneva, Switzerland
Posts: 4
I've a 350D GLE 2016. Navigation is terrible on my car. On highway it keeps repeating "exit the highway" and keep proposing different routes than what it has mapped in the beginning. In the city, it turns me around a point in a circle. The dealer updated it only once but after a few months became bullshit again. I'm wondering how Mercedes accepts these rubbish products from Garmin.
amirdelju is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes GLE Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome