Warning Lights - Mercedes GLE Forum
 
Thread Tools
post #1 of 4 (permalink) Old 10-20-2020, 07:27 PM Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 4
(Thread Starter)
Warning Lights

Good afternoon all,

This is Kevin and my first post. My wife's 2016 350 started up fine today but every warning light in the instrument cluster came on and stayed on. Nothing I have tried to rectify this has solved the issue. I thought it may be a battery issue but after not finding a word about where that is located I checked at the jumper posts and that seems to be fine. Does anybody have any suggestions?

Thanks for your time and assistance,

Kevin
KC Nix is offline  
post #2 of 4 (permalink) Old 10-23-2020, 07:36 PM Thread Starter
Junior Member
 
Join Date: Oct 2020
Posts: 4
(Thread Starter)
Here is what I found out today if anybody else has this issue. The battery had a dead cell which is what tripped the lights to all come on. Our local dealer did not have an OEM battery in stock and stated they were on back order for 3 weeks and they had no idea on when they would get them in. I replaced it with a new battery from Autozone. They only showed one battery for that vehicle and after getting it home I found it was 1.5 inches longer than the OEM. That made a huge difference as if I could have gotten it into the compartment it would have been sitting on the hold down bolts for the retainer clamp. The new battery didn't clear the idiot lights so it had to go into the shop. The mechanic told me that if you replace the battery with other than an OEM battery you have to use a code reader to tell the computer you are changing batteries before you disconnect it. I hope this helps anybody doing a DIY batt swap.
KC Nix is offline  
post #3 of 4 (permalink) Old 10-30-2020, 07:09 AM
Junior Member
 
Join Date: Oct 2019
Location: Washington D.C. area
Posts: 3
There is (2) battery one under the passenger front seat that's the main battery. There is a second battery for Auxiliary battery. If it's not in the rear hatch inside the rear panel I think it was the right side. Then the other location would be under the rear seat driver side.
amusa is offline  
 
post #4 of 4 (permalink) Old 11-01-2020, 05:40 PM
Junior Member
 
Join Date: Nov 2020
Posts: 6
Thanks! My warnings are making me a tough time too now
Gordonkn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes GLE Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome