9G-Tronic Transmission - Almost Everything You Need To Know - Mercedes GLE Forum
 
Thread Tools
post #1 of 6 (permalink) Old 03-31-2015, 01:52 PM Thread Starter
Senior Member
 
Join Date: Dec 2014
Posts: 180
(Thread Starter)
9G-Tronic Transmission - Almost Everything You Need To Know

Mercedes released full details on it's new 9G-Tronic transmission that can be fitted to rear and all-wheel-drive cars along with hybrid and plug-in hybrid applications. It's possible we'll see this transmission available right across all GLE models.


HDGFND is offline  
post #2 of 6 (permalink) Old 12-09-2015, 04:51 AM
Junior Member
 
Join Date: Dec 2015
Posts: 1
Hello! Greetings to all from London, UK

Was wondering if any GLE450 coupe owners experienced any issues with the 9G box - it being quite jerky especially on downshifts and generally "confused"..
Thanks
vla1976 is offline  
post #3 of 6 (permalink) Old 04-06-2017, 01:32 PM
Junior Member
 
Join Date: Apr 2017
Posts: 2
I have the same problem with my GLE43 AMG Coupe. It actually kicked so bad when downshifting that when I came to an stop the car turned itself off in the middle of the street and when I turned it back on the gearbox wasn't engaging and I couldn't move forward. It some how started working again after a few second. Is this problem a software issue or a mechanical one? my car has only done 11K KM.
alizandi is offline  
 
post #4 of 6 (permalink) Old 04-07-2017, 03:44 PM
Senior Member
 
Join Date: Jun 2016
Posts: 116
Quote:
Originally Posted by alizandi View Post
I have the same problem with my GLE43 AMG Coupe. It actually kicked so bad when downshifting that when I came to an stop the car turned itself off in the middle of the street and when I turned it back on the gearbox wasn't engaging and I couldn't move forward. It some how started working again after a few second. Is this problem a software issue or a mechanical one? my car has only done 11K KM.
Did any CEL come on ??
GLEM is offline  
post #5 of 6 (permalink) Old 05-04-2017, 02:09 PM
Junior Member
 
Join Date: Apr 2017
Posts: 2
Quote:
Originally Posted by GLEM View Post
Did any CEL come on ??
No nothing. Just an update, so I sent the car back to the dealership and they kept the car for couple of day. According to them they ran a new software update for the transmission and returned the car back. Unfortunately I still have the same problem specially when the car tries to downshift from 4th gear to 3rd and 3rd to 2nd when reaching a full stop. I still feel the big kicks but funnily the car's computer doesn't detect any faults. I am wondering if I might have a bad transmission or the issue is with the torque convertor?!
Anyways I'll be sending the car back to the dealership as I'm still facing the same problem.

I wish someone who had the same problem could tell me how to fix it cause it's extremely annoying to see the car running back gears like this.

Thanks
alizandi is offline  
post #6 of 6 (permalink) Old 05-08-2017, 03:37 PM
Senior Member
 
Join Date: Jun 2016
Posts: 116
Really sounds like a case of hardshifting due to a lack of transmission fluid or something.
GLEM is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes GLE Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome